Revolution Slider. Llegó la hora de cambiar a PHP 7

No os asustéis porque hace bastante tiempo que uso la versión 7 de este lenguaje de programación y aunque no he hecho grandes proyectos “a pelo” si que hay muchos scripts sueltos que están pululando por la red desde finales de los 90 o principios del 2000 que no he cambiado nada porque funcionan perfectamente y siempre tengo muy en mente ese dicho de los informáticos que dice que si algo funciona, no lo toques.

Pero esta vez, no ha sido ninguno de mis scripts el culpable que se parara la web de uno de mis clientes. Ha sido un plugin de WordPress, concretamente Revolution Slider. Suelo actualizar muy a menudo wordpress por los problemas de seguridad que ha dado en el pasado y que posiblemene de en el futuro. Personalmente considero que es un CMS genial, muy simple de utilizar y que cualquier persona con mínimos conocimientos de informática puede “mantener” una web muy completa. Posee extensiones o pluggins como Woocomerce que lo convierten en una tienda virtual muy completa para alguien que no necesita complicarse la vida mucho y todo o casi todo de esto de forma gratuita o por un precio irrisorio y con acceso total al código fuente.

Gracias a tener acceso a este código fuente es por lo que hoy he podido solucionar este problema con la web. Resulta que el proveedor de hosting de mi cliente, ha decidido dejar de soportar php 5.x en sus servidores y si queremos usarlo, hay que pagar una cantidad totalmente desproporcionada al mes con respecto a lo que paga por el hosting. Por ello, le he indicado en el panel de control que la versión por defecto de php a utilizar es la 7.

WordPress se la ha tragado sin problemas pero uno de los scrips, Revolution Slider y su error “wp-content/plugins/revslider/inc_php/db.class.php:29” parece que no recibe actualizaciones desde hace mucho tiempo. He intentado acceder a la web del desarrollador y me encuentro con un error 404. La última opción que me quedaba era ponerme manos a la obra y destripar el código fuente cruzando los dedos para que no hubiera muchas funciones que cambiar.

Accedemos al directorio donde tenemos instalado nuestro wordpress, nos dirigimos a la carpeta /wp-content/plugins/revslider/inc_php/ y allí editamos el fichero db.class.php.

Gracias a Dios, está todo muy bien organizado y no tenemos código tipo espagueti. Buscamos la siguiente línea:

y la cambiamos por esta otra (he comentado la antigua para que se vea la diferencia):

Guardamos los cambios y a funcionar otros muchos años mas.

, , , ,

Deja un comentario

Tu dirección de correo electrónico no será publicada. Los campos obligatorios están marcados con *